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1 Interface Overview 

The interactive interface of NcStudio Phoenix Stone Machining System is as 
follows: 

 

1. Drawing toolbar 

2. Window switch buttons 

3. Menu bar 

4. File toolbar 

5. Drawing/trace window 

6. Status bar 

7. Coordinate display area 

8. Machine operating area 

9. Buttons for common operations 

10. Buttons for port control 

11. Buttons for movement control 

12. Technic setting area 
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1.1 Drawing Toolbar 

It includes four parts: 

• View tools 

   

• Drawing tools 

   

• Settings for toolpath 

   

• Layer 

   

Please refer to Drawing Graphics and Setting Toolpath for details. 
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1.2 Window Switch Buttons 

It is used to switch between Draw window and Trace window: 

 

The active button is highlighted in blue. 

• Draw window 

  Used to draw the machining toolpath and set its corresponding machining 
technics. 

• Trace window 

  Used to view the real-time toolpath in running or simulation status of the 
machine. 

1.3 File Toolbar 

It includes five common tools related to process toolpaths and its related technic 
parameters: 

•  Open 

  Used to load a file. 

– In Draw window, load a ST file, which just contains related technic 
parameters and can not be machined directly. 

– In Trace window, load a NC, DXF, PLT, ENG or NCE file, which can be 
machined directly. 

•  Save 

  Used to save the set technic parameters. 

  Before machining, the operation is required. 

•  Save As 

  Used to save the set technic parameters as a ST file. 

•  Import 

  Used to import a DXF file and a file containing related technic parameters. 

•  Export 

  Used to export a DXF file and a file containing related technic parameters. 
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1.4 Status Bar 

It includes two parts: 

 

1. It shows the current status of the machine. 

  Possible status includes the following: 

– E-stop 

– Idle 

– Running 

– Pause 

2. It shows the current system log. 

  Click on area ②. Log dialog box will pop up: 
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  The type of log includes the following: 

– : It shows machine actions in running status. 

– : It reminds operators of potential danger. At this time, the machine 
can still work in a short time. 

– : It shows error message. Such an alarm must be cancelled before 
continuing machining. 

1.5 Coordinate Display Area 

It displays two coordinate systems of the machine: 

• Machine coordinate system 

• Workpiece coordinate system 

After doing Homing, the sign  will appear in front of the corresponding axis: 
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1.6 Machine Operating Area 

It is used to control the machine manually. 

 

It includes the following: 

1. Axis direction button 

  Used to move each axis towards positive or negative direction: 

– Press X- / X+ / Y- / Y+ / Z- / Z+. The machine moves at jogging speed. 

– Press Rapid and X- / X+ / Y- / Y+ / Z- / Z+. The machine moves at rapid 
jogging speed. 
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2. Mode Buttons 

  It includes three modes: 

– Jog mode 

  Press an axis direction button. The machine keeps running until you 
release the button. 

– HW mode 

  The machine is controlled by handwheel. 

– Stepping mode 

  Click an axis direction button. The machine moves 0.01 mm(inch), 0.1 
mm(inch), 1 mm(inch) or customized step size. 

  The default customized step size is 5mm(inch) and the value should not 
be too large to avoid damage due to misoperation. 

  Note: Please do not click frequently for the system needs a certain time to execute the 
command. 

3. Current feedrate 

  It shows the current feedrate of the machine. 

4. Override control 

  Drag the slider to change G00 override, feed override and spindle override. 

5. Current tool No. 

  It shows the currently used tool number. 
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1.7 Buttons for Common Operations 

It includes buttons for eight common operations: 

•  Unload 

  Used to unload the loaded program files. 

•  Homing 

  Used to open Homing dialog box. 

•  Origin 

  Used to move each axis to the workpiece origin. 

•  Fixed Point 

  Used to move each axis to the set fixed point. 

•  HW Guide 

  Used to enable HW mode. 

•  Clear 

  Used to open Clear dialog box. 

•  MDI 

  Used to open MDI dialog box. 

  At most 8 user instructions can be input. 

•  Simulation 

  Used to enable simulation mode. 

  After saving all drawings and settings, it is suggested to enable this function to 
check whether the trace is consistent with the expectation. 



上海维宏电子科技股份有限公司 
SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 9 / 35 

1.8 Buttons for Port Control 

They are used to quickly turn on or turn off the following I/O ports: 

 

When the button is highlighted in green, it indicates the related port is ON. 

1.9 Buttons for Movement Control 

They are used to control the movement of the machine. 

•  Start 

  Used to start machining. 

– Start to machine the set parameters if a file is saved directly. 

– Start to machine the loaded program if a program file is loaded. 

•  Pause 

  Used to pause machining. 

•  Stop 

  Used to stop machining. 

•  Resume 

  Used to resume machining from the exact interrupted position 

– If a grinding wheel is enabled, the system resumes machining the 
interrupted graphic. 

– If a program file is executed, the system resumes machining from the 
start of the interrupted line. 
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1.10  Technic Setting Area 

It is used to set the specific parameters required for each technic in Draw window. 

 

1. Technic bar 

2. Parameter setting 

Please refer to Setting Technic Parameters and Technic Parameters for details. 

2 Quick Start 

NcStudio Phoenix Stone Machining System is easy to operate with its own 
drawing function and technic setting function. 

To operate NcStudio Phoenix Stone Machining System, do the following: 

1. To debug the system, set tool magazine. 

2. Draw graphic. 

3. Set toolpath. 

4. Set technic parameters. 
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3 Setting Tool Magazine 

Magazine function can manage tool efficiently and improve machining efficiency. 
This chapter mainly introduces the following operations in NcStudio Phoenix 
Stone Machining System： 

• Setting tool 

• Setting tool calibration 

• Managing linear tool magazine 

3.1 Setting Tool 

To set tool, do the following: 

1. Click Operation → Tool Setting. Tool Setting dialog box pops up: 

   

2. Double click corresponding parameter. Parameter setting input box pops up. 

3. Enter the parameter value in the input box. 

  Please refer to List of Parameters for details of the parameters. 
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3.2 Setting Tool Calibration 

To set tool calibration, do the following: 

1. Click Operation → Tool Calibration Setting. Tool Calibration Setting dialog 
box pops up: 
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2. To select calibration modes, do one of the following: 

– Click One-click Calibration. The system automatically does the 
following: 

1. Execute tool change and then fixed tool calibration. 

2. Set the calibration value to Z-axis offset of corresponding tool. 

3. Repeat step 1 and step 2 until all tools have been fixed. 

– To select fixed calibration, do the following: 

1. Move X-axis and Y-axis above tool sensor. Then click One-click 
XY. 

2. Set parameter of Fixed Calibration Z. 

3. Click Fixed Calibration. 

  The system will set the calibration result to Z-axis offset of current tool 
No. 

– Click Float Calibration. The system does the following: 

1. Execute float calibration with current tool No. 

2. Set the calibration value to Z-axis offset of current coordinate 
system. 

3.3 Managing Linear Tool Magazine 

To manage linear tool magazine, do the following: 

1. Click Operation → Linear Tool Magazine. Linear Tool Magazine dialog box 
pops up: 

   

2. Select Linear Tool Magazine Type. 

3. Enter the parameter value in the input box. 

  Please refer to Tool Setting Parameters for details of the parameters. 
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4 Drawing Graphic 

This chapter mainly introduces the following operations in NcStudio Phoenix 
Stone Machining System: 

• Setting attribute 

• Calling view tool 

• Calling drawing tool 

• Managing a layer 

4.1 Setting Attribute 

To set attribute, do the following: 

1. Click Draw to switch to Draw window. 

2. Right click to select Attribute. Attribute dialog box pops up: 

   

  At this time, the graphic should not be selected. 

3. Set related attribute parameters. 

– SimuColor: Specify the trace color of each instruction in Trace window. 

– Show Config: Select the displaying color of each configuration and 
whether to check the displaying color and Text. 

– Manage Layer: Select whether to only use configuration layer when 
importing a DXF file. 

4. Click Confirm to close Attribute dialog box. Above setting takes effect 
immediately. 
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4.2 Using View Tool 

To call view tool, do the following: 

1. To select view tool, do one of the following: 

– In menu bar, click View → Fit to window / Move view/ Zoom in / 
Zoom out. 

– In drawing toolbar, click view tools. 

– Right click to call context menu. 

2. To execute related view tool instructions, do the following: 

– Select Fit to window, and click to automatically fit to Draw window. All 
graphics will be shown in the middle of the window. 

– Select Move view, and do one of the following: 

• Hold the left mouse button and drag the object. 

• Hold down mouse wheel and drag the object. 

– Select Zoom in / Zoom out, and do one of the following: 

• Click the left mouse button repeatedly to zoom in/out the graphic. 

• Scroll the mouse wheel to zoom in/out the graphic. 

4.3 Using Drawing Tool 

Before drawing, do one of the following to call drawing tool instructions: 

• In menu bar, click Draw → Select / Polyline/ Rectangle / Circle / Ellipse / 
Arc / Elliptic Arc. 

• In drawing toolbar, click drawing tools. 

  When calling instructions of rectangle, circle, arc and ellipse arc to draw 
graphic, right click corresponding tool icon, then left lick to select drawing 
method. 

  The default drawing direction of arc and elliptic arc is counterclockwise 
direction. 

  The default machining direction of the drawn graphics displays automatically. 
Except for rectangle, the default machining direction of polyline, circle, ellipse, 
arc and elliptic arc is counterclockwise direction. 
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4.3.1 Using Select Instruction 

Select is used to edit graphic and set technic parameters. 

To use select instruction, do the following: 

1. To select graphic, do one of the following: 

– Click primitives one by one. 

  A primitive is the smallest unit to draw a graphic. Click a graphic in 
Draw window, and a primitive is what is selected. 

– Hold the left mouse button to drag the selected primitive. 

• Drag from upper left to lower right: Primitives contained in select 
box will be selected. 

   

• Drag from upper right to lower left: Primitives intersected with 
or contained in select box will be selected. 
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  When the graphic is selected, Node No., Feature point and Center point will 
be shown as follows: 

   

2. Optional: To change graphic by Feature point or Center point, do the 
following: 

– By adjusting feature point: 

1. Click a feature point. 

2. Drag mouse to specify direction and angle. 

3. Enter the size that needs change. 

– To change the coordinate of graphic by moving center point: 

1. Click the center point. 

2. Drag mouse to the target position. 
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4.3.2 Drawing a Polyline 

To draw a polyline, do the following: 

1. To specify a start point, do one of the following: 

– Click in Draw window. 

– Enter coordinate point in the input box. 

   

  Separate coordinates with comma. Format: X-axis coordinate, Y-axis 
coordinate. 

2. To specify the next point, do one of the following: 

– Click in Draw window. 

– Enter length value in the input box. 

– Enter coordinate point in the input box. 

4.3.3 Drawing a Rectangle 

To draw a rectangle, do one of the following: 

• Select Two points, and specify the following in order: 

1. A start point. 

2. An end point on the diagonal. 

• Select Length width, and do the following: 

1. Specify a start point. 

2. Enter the length and width. 

Pick points in Draw window or enter coordinate in the input box to get the above 
specified points. 
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4.3.4 Drawing a Circle 

To draw a circle, do one of the following: 

• Select Center, radius/diameter, and do the following: 

1. Specify the circle center. 

2. Enter radius/diameter value. 

• Select Two points, and specify a line as the diameter. 

• Select Three points, and do the following: 

1. Specify three points. 

2. Draw a circle with the arc shaped by the three points. 

• Select Tangency, tangency, radius, and do the following: 

1. Specify two tangency points. 

2. Enter radius value. 

• Select Tangency, tangency, tangency, and specify three tangency points. 

Pick in Draw window or enter coordinate in the input box to get above specified 
circle center, radius, diameter and points. 

4.3.5 Drawing an Ellipse 

To specify two points to draw a rectangle, do one of the following: 

• Pick two points in Draw window. 

• Enter coordinate in the input box. 

Ellipse is tangent to the four sides of the rectangle. 
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4.3.6 Drawing an Arc 

To draw an arc, select one of the following methods and follow the order in the 
name of the method: 

 

In the methods, angle refers to included angle of the arc. Direction refers to start 
point’s tangential direction of the arc. And chordlength refers to chord length. 

Pick in Draw window or enter coordinate or value in the input box to get the 
specified start point, circle center, endpoint, angle, chord length and radius. 

e.g. To draw an arc by selecting Start point, center, endpoint, do the following: 

1. Specify a start point. 

2. Specify a circle center. 

3. Specify an end point. 

4.3.7 Drawing Elliptic Arc 

To draw an elliptic arc, do one of the following: 

• Select Inscribed Ellipse in Rectangle, and do the following: 

1. Draw an ellipse according to the painting of ellipse. 

2. Specify a start point. 

3. Specify an end point. 

• Select Center, Axis length, and specify the following in order: 

1. The center. 

2. An endpoint of one axis. 

3. The length of another axis. 

4. A start point. 

5. An end point. 
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• Select Axis length, Endpoint, and specify the following in order: 

1. An endpoint of one axis. 

2. Another endpoint of the axis. 

3. The length of another axis. 

4. A start point. 

5. An end point. 

Pick in Draw window or enter coordinate or value in the input box to get above 
specified start point, axial length and endpoint. 

4.4 Managing a Layer 

Layer is used to deal with a group of graphics without affecting other graphics. 

To manage a layer, do the following: 

1. To call Layer instruction, do one of the following: 

– In menu bar, click View → Layer. 

– In drawing toolbar, click . 

– In Draw window, right click to select Layer. 

  Layer dialog box pops up. 

   

2. In the dialog box, do the following: 

– Set Name, FillColor, Outline, Linetype, Linewidth and Transparency. 

– Optional: Check TurnOn/TurnOff, Frozen, Locked, FillCheck. 

– Create a new layer. 
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5 Setting Toolpath 

This chapter focuses on the following settings related to toolpath in NcStudio 
Phoenix Stone Machining System: 

1. Setting origin 

2. Changing machining order 

3. Changing machining direction 

4. Setting lead line 

5.1 Setting Origin 

To set workpiece origin, do the following: 

1. Do one of the following: 

– In menu bar, click View → Set Origin. 

– In drawing toolbar, click . 

2. Click on the target position in Draw window. The position sets as the 
workpiece origin. 

5.2 Changing Machining Order 

To change machining order, do the following: 

1. Do one of the following: 

– In menu bar, click View → Change Machining Order. 

– In drawing toolbar, click  . 

2. Click on the target primitives in order. The machining order starts from one. 

If you need to change the machining order of the subsequent primitives from a 
selected primitive, right click to select Change Machining Order. 

5.3 Changing Machining Direction 

To change machining direction, do one of the following: 

• In menu bar, click View → Set Machining Direction and click on the target 
primitive. 

• In drawing toolbar, click  and click on the target primitive. 

• Select one or several primitive(s) and right click to select Change Machining 
Direction. 
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5.4 Setting Lead Line 

To set lead line, do the following: 

1. Select one or several primitive(s), and do one of the following: 

– In menu bar, click View → Set Lead Line. 

– In drawing toolbar, click . 

  Set Lead Line dialog box pops up: 

   

2. Set parameters of lead-in line and lead-out line and select lead-in method and 
lead-out method for the selected primitive(s). 

  If the selected primitives are continuous, you just need to to set parameters of 
lead-in line for the first primitive and set parameters of lead-out line for the 
last primitive. 

3. Click OK. The set lead line automatically shows on the selected primitive(s) in 
Draw window. 

Note: If the machining direction of a primitive is changed, its lead-in line and lead-out line of will be 
exchanged automatically. Thus, if the setting does not accord with the reality, please set it again. 
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6 Setting Technic Parameters 

This chapter focuses on setting the following technic parameters in NcStudio 
Phoenix Stone Machining System: 

• Setting basin parameters 

• Setting front retaining water parameters 

• Setting rear retaining water parameters 

• Setting outline parameters 

• Setting hole opener parameters 

For details of technic parameters, please refer to Technic Setting Parameters. 

6.1 Setting Basin Parameters 

This operation is only available to a rectangular, a circle and an ellipse. 

To set technic parameters of basin, do the following: 

1. In technic setting area, select Basin to switch to its parameter setting area: 

   

2. Select a primitive. Its positioning method and size automatically show in area 
① and the information can be modified manually as needed. 

3. Check the needed machining technic in area ② (Check more than one if 
needed). 

4. Optional: Check Hole Opener to punch a hole in basin. 

5. Set basic parameters in area ③. 
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6. Click Tool Setting. The dialog box Tool Setting pops up: 

   

– If Cutting is checked in area ②, set parameters of Cutting. 

– If Grinding is checked in area ②, set parameters of Grinding. The Step 
No. 1~7 corresponds to grinding 1~7 respectively. 

– If Hole Opener is checked, set parameters of Hole Opener. 

7. Click Set Basin to set the selected primitive as basin technic. 

  The color of the selected primitive turns to the set color and the selected 
primitive will be machined according to the above set parameters. 
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6.2 Setting Front Retaining Water / Rear Retaining Water / 
Outline Parameters 

This operation is only available to unclosed graphics, such as polyline, arc, etc. 

To set technic parameters of front retaining water/rear retaining water/outline, do 
the following: 

1. In technic setting area, select Front Retaining Water / Rear Retaining Water 
/ Outline to switch to its corresponding parameter setting area: 

• Front Retaining Water 

   

• Rear Retaining Water 

   

• Outline 
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2. To set deceleration point for front retaining water and rear retaining water, do 
the following: 

1. Select a primitive. The selected primitive shows as a dotted line and the 
node index starting from zero appears: 

   

2. Click + or - to switch to the node that you would like to set as the 
deceleration point. 

   

3. Click Set Dec Point. The selected node sets as the deceleration point. 

  More than one deceleration point can be set. 

3. Optional: Take the length from node 2 to 3 as an example. To modify its length, 
do the following: 

1. Click + or - to switch to node 3. 

2. Do one of the following: 

• Enter a value in the input box of Coor X or Coor Y to adjust 
coordinates of node 3. 

• Enter a value in the input box of Line Length. 

4. Set the following parameters: 

– Deceleration distance 

– Deceleration rate 

– Current direction 

– Tool compensation type 
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5. Optional: To enable grinding wheel, do the following: 

1. Check Enable Grinding Wheel. 

2. Set Z Down Feedrate in its input box. 

3. Click Tool Setting. Tool Setting dialog box pops up: 

   

4. Set related parameters for grinding wheel. 

6. Click Set Front Retaining Water / Set Rear Retaining Water / Set Outline to 
set the selected primitive as front retaining water/ rear retaining water/ 
outline. 

  The color of the primitive turns to the set layer color, and the primitive will be 
machined according to the above set parameters. 
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6.3 Setting Hole Opener Parameters 

This operation is only available to a circle. 

To set technic parameters of hole opener, do the following: 

1. Select a circle. 

2. In technic setting area, select Hole Opener to switch to its parameter setting 
area: 

   

3. Check Hole Opener to enable hole opener. 

4. Set the following parameters: 

– Tool No. 

– Z Down Depth 

– Z Down Speed 

– Spindle Speed 

5. Click Set Hole to set the selected circle as hole opener. 

  The color of the circle turns to the set layer color, and the circle will be 
machined from its center. The size of the hole opener is the same with the hole. 

  At most 6 holes can be set. 
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7 Operation Example 

This chapter shows how to use NcStudio Phoenix Stone Machining System to 
machine the standard arc-angled plate. Take outer contour technic as an example: 

 

Graphic Analysis 

Reason: 

• This graphic consists of four lines and four arcs. 

• Each arc is a three fourths circle. 

• Each circle center is the intersection of extension cords of adjacent lines. 

Suggestion: 

Take start point, center, angle drawing method to draw the four arcs. 

Operation 

Please refer to the following video for operation. 

https://v.qq.com/x/page/p07115gr13o.html 
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8 List of Parameters 

This chapter introduces important parameters in the following: 

• Tool setting 

• Linear tool magazine management 

• Technic setting 

8.1 Tool Setting 
Tool No. 
Tool No. is the number of each tool and can be 31 at most. 

Tool Diameter 
Tool diameter is used in radius compensation during machining. 

X/Y/Z Offset 
X/Y/Z offset is the offset value of each tool and can be set directly or by using tool 
sensor. 

X/Y/Z Tool Position 
X/Y/Z tool position is the machine coordinate of each tool and used during tool 
change. 

8.2 Linear Tool Magazine Management 
Tool Change Ahead Position of X/Y/Z 
Tool change ahead position of X/Y/Z is used to set machine coordinate of ahead 
position during automatic tool change. 

Manual Set Offset 
Set current Z-axis machine coordinate to Z-axis offset corresponding to current tool. 

Current Tool No. 
Current tool No. is used to change current tool No. directly and call corresponding 
tool offset. At this time, there is no tool change. 

8.3 Technic Setting 
Ellipse Division Precision 
Ellipse division precision refers to ellipse precision. 

The smaller the value is, the higher the precision is. 

Too high precision may cause machine oscillation. Too low precision may cause 
ellipse distortion. 

The recommended setting range of precision is (0.1,1). 
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Lead Line Radius Override 
Lead line radius override meets the following formula: 

Lead line radius of arc plunge (R2)= Lead line radius override * Corresponding tool 
radius (R1). 

e.g. When the wheel of basin is grinded, the arc shapes from plunging point to cut 
point: 

 

Z Plunging Point Height 
Z-axis plunging point is above the workpiece. Height of Z-axis plunging point refers 
to the height of Z-axis starting to plunge when the machine is cutting. 

Z-axis plunges from the highest position to this position in G00 speed. When Z-axis 
arrives at the plunging point position, Z-axis starts to plunge in plunging speed of 
each set tool. Plunging point refers to the fixed left feature point: 
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Sheet Size 
Sheet size includes the length, width and thickness of sheet and displays in graphic 
immediately. 

Sheet size affects the position of graphic, and must be entered according to actual 
sheet size. 

Reserved Distance 
If the hole opener is enabled, the hole opener will punch a hole at the plunging point 
before the machine starts machining. 

Thus, this parameter refers to the distance from the outer edge of the hole opener to 
the cutting edge: 

 

Cutting Angle 
If the hole opener is disabled, the machine starts machining at the set cutting angle. 
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Deceleration Distance 
There is a deceleration distance before and after the set deceleration point. 

Actual feedrate within the deceleration distance = Set feedrate * Deceleration 
override 

 

Current Direction 
Unchange: Current direction is the same with the arrow direction in the drawing. 

Reverse: Current direction is opposite to the arrow direction in the drawing. 

Grinding 
Check to select the corresponding grinding wheel to start machining. 

Cutting Depth 
Cutting depth from the workpiece origin of Z-axis. 

Machining Speed 
Speed during machining with grinding wheel. 

Spindle Speed 
Spindle speed during machining with grinding wheel. 

Engagement 
The feed engagement when a grinding wheel is enabled after cutting. 

Each engagement = Engagement / Engagement times 

Margin 
The difference between the drawing size and the size after the first-time machining. 
The maximum engagement times for margin is 2. 
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Enable Margin 
Enable margin or engagement (not both). 

The values of margin and plunge distance have no correlation and they are all based 
on the drawing size. 
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